Cinema 4D R20 - Plugins need to be updated...
 By PropShop Admin on Wednesday 05 September 2018 - 23:21:34


Hi Folks,

As many have noticed, Cinema 4D R20 has been (or being) released as I type this.  This C4D update no longer supports plugins compiled for earlier versions of Cinema 4D [similar to when R12 was first released].

This update does not only require a (relatively simple) re-compile - it requires substantial changes to the code to work with a newer R20 SDK (software development kit).

Unfortunately, while those changes are underway, they are not completed on any of my plugins at this time.

As mentioned, the changes/work to be done is fairly substantial, so I do not currently have any estimates or announcements for when they will be completed.  This set of changes might also affect my pricing (and/or update pricing) strategy - which has been unchanged for the past 10 years or so - but I haven't made any decisions on that yet.

I will post more information as I have it - thanks in advance for our patience.


- Keith





 printer friendly   create pdf of this news item