News Item: : Riptide Pro - v2.6.1 Bug Fix Clarification
(Category: Cinema 4D Plugins)
Posted by PropShop Admin
Monday 05 February 2018 - 23:20:54

I just wanted to clarify/expand a bit more on the "bug fix" mentioned in the v2.6.1 release notes below...

Since v2.6 was released, I have had occasional reports - pretty much exclusively from Mac users - of the plugin crashing when loading a .obj file.  They were able to revert back to using the v2.5 plugin as a work-around. I have had some trouble tracking it down (issues with my Mac) and could not reproduce it - nor have I had any reports of it on the PC... until about a week ago, when a user reported a similar problem on the PC, with R16...

While investigating that, I also couldn't reproduce the problem, until I tried it with R16 - sure enough, the plugin crashed on some particular .obj files, but not others.  Note that those problem .obj files all imported fine on the PC with R14, R15, R17, R18 and R19 using the same plugin build, adding to the confusion.

At any rate, while adding the new "unique material names" feature that is also included in the v2.6.1 build (see below), I suddenly ran into the crash bug with R14, so I was able to do a debug build and figure out where it was happening...

Basically, whether or not you experienced the bug/crash had to do with what amounted to an uninitialized variable (more specifically, a sometimes initialized variable, and/or sometimes poorly initialized varible), having also to do with whether the .obj file contained nGons (>4 sided polygons) or not.

Anyway, the point of this post is that this bug has been fixed(!) and will hopefully now allow Mac users and/or PC R16 users (and really ALL users) to successfully use the plugin, as intended - ALL R14 or later users should download the update (the Mac build included in the archive is actually a R12 or later build).

Cheers.


This news item is from Spanki's Prop Shop
( http://skinprops.com/news.php?extend.36 )